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Chang  7/26/2010 

 

Trabeculae Analysis Protocol for BioQuant OSTEO 2010 

Novack’s lab 

 

General Info (READ FIRST) 
 

 This protocol only covers a few features in the BioQuant, which are the histomorphometry 

analysis for rodent trabecular bone.  
 

 There is much subjectivity during analysis, such as choosing ROI, outlining bone, and 

defining osteoblasts/osteoclasts. The position at which you cut bone into slices adds variance 

too. Those factors are not a big issue as long as you can be consistent during the 

measurements and have enough samples. In order to be more objective, BioQuant users 

should not know which slice they are working on. 
 

 The trabeculae underneath the growth plate in the proximal end of tibia are the recommended 

area for the analysis of rodent trabecular bone. 
 

 To set the objective of the microscope, usually 4× is for tissue volume, 10× is for trabecular 

bone and osteoclasts (OC), and 20× is for osteoblasts (OB). 
 

 Stitched high magnification image is highly recommended as opposed to manual move mode 

because of the following reasons: (1) do not need to worry about positioning errors, such as 

bumping stage accidentally or clicking wrong buttons; (2) you have a image file that can be 

stored and measured again; (3) orientation of bone slices can be easily modified to facilitate 

the measurement. 
 

 All the measurements only apply to the current ROI (Region of Interest) area. You will need 

to redefine it often. 
 

 The system files (e.g., data volume file, array list file, and calculation set file) used in this 

protocol are customized for routine rodent trabeculae analysis. They are manually defined by 

users and may not be found in other BioQuant systems.  

 

 It is recommended to follow the order of the procedures in Analysis section shown below 

because of the following reasons: (1) some parameters are used to calculate some of the later 

parameters; (2) you only can undo some of the procedures; (3) the program may freeze from 

messy procedures. Once you find you cannot draw anything to the image, you have to exit 

and restart the program. 
 

 Use a right click of your mouse to get out of the Image Window if your cursor gets stuck. 
 

 Clear Overlay button  in the Shelf window doesn’t erase data, just clears the Image 

Window. You will need it to hide the markings/tracings. 
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 Toggle Display Threshold button  (or Ctrl + D) in the Shelf window will be useful if you 

do not want the solid yellow threshold of bone to get in the way when you define OB/OC 

surface. 
 

 System Redraw button  (or Ctrl + R) in the Shelf window puts the markings/tracings back. 

You will need to redraw often. 
 

 

 

 

 

 

Reservation 

       There are 3 BioQuant systems on medical campus. If you want to use the one in Dr. Deborah 

Novack’s lab (Yalem 602), please make a reservation in Google Calendar. Account: 

Histo.BioQuant@gmail.com, password: pathoquant10. If you have to stay late or work in weekend, 

you can ask for a key to enter the room. In addition, please sign in a register sheet beside the 

microscope.  

 

 

Contact 

       If you encounter problems, please contact Deb Novack (454-8472, novack@wustl.edu) or 

Chang Yang (454-5975, cyang@dom.wustl.edu). 
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Set Up Working Environment 
 

1. Make sure you read and understand the General Info in the first page. 

 

2. Launch BioQuant OSTEO 2010 from desktop. 

 

3. Get image from microscope: in main menu of BioQuant, go to Image -> Open QImaging 

Camera... If microscope is on, this should turn the Image Window white instead of black. If 

not, check the output from the microscope (top right, round slider), which should go to 

camera or eyes+camera. For bright field, check that dial on front of microscope is on #1. Use 

#4 for tetracycline/calcein fluorescence. These microscopic settings only apply to the one in 

Novack’s lab. 

 

4. Adjust image: place your slide on the scope. Along the top bar of icons, click Auto Expose 

button . Now your tissue should show. Focus to screen and put a field with some or all 

white (no tissue) on the screen and choose White Balance button . If you want to adjust the 

image manually, click Image -> Camera Setup… and you can have more control in the 

Camera Settings window. Click Enable Large Image Capture button  if you want to save 

1280 × 960 image and it is recommended. 

 

5. Make stitched image: take a series of high magnification pictures with about 20% 

overlaps to cover the whole area to be analyzed, and then save them individually (File -> 

Save Image(s) -> Save Single Image…). The dimension of each picture should be 1280 × 

960. Stitch them together in a third-party software. If you use Photoshop CS2, use File -> 

Automate -> Photomerge… Once you get the big stitched image, rotate it to an orientation in 

which the horizontal axis of the growth plate is parallel to the top edge of the image by using 

Image -> Rotate Canvas -> Arbitrary…. Adjust color, brightness, or contrast if necessary. 

Open it in BioQuant by clicking Load Image button  on main toolbar or File -> Load 

Image(s) -> Load Single Image… You will see your stitched image in the Image Window. A 

Large Image Navigator window will show up and click Shrink/Expand Image button  , 

now you can see the whole image in the Image Window and it is ready to define a ROI of 

tissue volume. 

 

6. Choose data volume: click Open Data Set icon  on 

main toolbar or File -> Open Data Set… from main menu. 

Highlight General Bone Volume in Data Volumes box and 

General Bone Master in Data Sets box, and click Open 

button. Data volume defines what kind of measurements 

will be used in the following analysis and can be seen as a 

project name, so stick to the same one for same 

experiments.   

 

7. Choose data set: click Quick Data Set button  on main toolbar or File -> New -> Quick 

Data Set… from main menu. Name your data set and leave Current Data Set selected. Click 

Create button. Data set is where the results from a specific sample store, so slide ID works 

well. 
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8. Choose arrays for measurement: in Select Arrays window, under Select menu, Select All 

Arrays if you need all of them or Load Selected List then choose General Bone in pop-up 

window if your purpose is trabecular bone analysis. If the Image Window screen turns solid 

yellow after you load the arrays, use the Clear 

Overlay button  in Shelf window to see your 

image. Selected arrays here define what kind of 

parameters you want for the following 

measurements. The number in the parenthesis at the 

end of every array denotes how many values are 

measured by it.  

 
9. Choose calculation results: Find Calculations window, 

click File -> Load Set from File…, and choose General Bone 

in the BQ Open File window. Different measurements are 

found under the A, B, and C tabs. The items in the tabs of 

Calculations window are the items you will see in your final 

results spreadsheet. Each item equals a parameter of 

measurement.  

 
10. Choose color assignment (optional): click Option -> 

Customizing… on the main menu. In the color box of Customizing 

window, make sure Threshold and Preview are assigned to 

different color. For later on, if you see nothing change when you 

click the Preview button, you might need to go back here to 

change it, as you will need that feedback. Yellow Threshold and 

blue Preview are recommended. 
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Define Your Own System Files 
 

General Bone Volume and General Bone Master in step 6, General Bone file in step 8, and General 

Bone file in step 9 are created manually by users for trabeculae analysis. You can make your own 

system files to match your need and facilitate your analysis. 

 

Define your own data volume and data set 
    Click File -> New -> New Data Set… from the main menu. A wizard called BIOQUANT New 

Data Set popup. There are 4 steps to create your own data set. In step 1 window, you can choose to 

either create a new data volume or modify an existing data volume. In step 2 window, name your 

own data volume. In step 3 window, select your own template. For the purpose of rodent trabeculae 

analysis, Bone Rodent Trabecular Templ. is recommended. In step 4 window, name your data set. 

Now, your own data volume and data set will show in the Open a Data Set window. 
 

       
 

Define your own array list 
    Follow these steps: in Select Arrays window, Select -> UnSelect All Arrays -> double click the 

arrays you want in the Available Arrays box -> repeat until all the arrays you want are in the 

Selected box -> Save Selected List -> name your bqa file. By default, your own array list file will be 

saved to C:\BQOSTEO\Selected Lists. 

 

Define your own calculation set 
    In Calculations window, choose File -> Select New 

Arrays… A window called Select Calculation Arrays 

shows up, put the parameters you want in to different 

pages. There are 5 pages you can choose, and normally 3 

pages are enough. The parameters in page A will show in 

tab A in the Calculations window. Once you are done 

with selecting, save your own calculation arrays by 

choosing File -> Save Set to File… -> name your bqc 

file. By default, your own calculation set file will be 

saved to C:\BQOSTEO\Calculation Lists. 
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Analysis 
 

1. Set magnification and topography: In Parameters window, make sure the microscope 

objective in use matches the magnification selected. If a stitched high-power image is loaded, 

set the Mag accordingly. Start with the 4x objective to select your area of measurement. 

Check the box for Save Topo as all the topographic info will be saved (saved in array D5 by 

default) and showed in Overview window. 

 

2. Set a consistent ROI for tissue volume measurement. Click the wrench icon  on main 

toolbar if ROI Tools window is not there. In Create tab of ROI Tools window, choose 

Rectangle from Type drop-down menu. Now ignore the green box that appears in the Image 

Window. Set the height and width. Click Define ROI button, cursor will show up in the Image 

Window in the shape of a cross with a dark-blue rectangle box round it. When you are 

satisfied with the position of ROI, left click to fix it and right click to get out.  

A consistent ROI for all the bone slices is critical for the whole analysis and how to set it 

is somewhat tricky. To balance the pros and cons between irregular ROI tracing growth plate 

and rectangle ROI with fixed size, a rectangle ROI with a fixed height and distance to growth 

plate and a variable width might be practical.  

Maintaining the horizontal axis of ROI parallel to the growth plate helps to maintain 

consistency among samples. A constant distance to growth plate helps too. 

Although bone slices can vary, it is recommended to have a ROI with enough height and 

about 100µm distance between the top edge of the ROI and bottom edge of the growth plate. 

Stamp Tools can help you to measure the distance. Click the stamp icon  on main toolbar, 

choose Diagonal line type and set Distance in the Stamp Tools window. Click Define button 

to draw a line in the Image Window, which will give you an idea of distance. Erase All button 

can delete defined lines. 

 

3. Measure tissue volume (TV). Highlight D6 in the Selected box of the Select Arrays 

window. Now, your ROI turns solid yellow with a green edge. Find Auto Measure window 

(or you can click the compass icon  on the main toolbar if it is not there), click Preview 

button in General tab. Your ROI will have an extra blue edge which is the color set in the 

Customizing window. Then click Measure button to obtain tissue volume (TV). Now ROI 

turns light blue. You will see a box that appears in the Overview window. The TV value will 

appear in the List Current Array window and the number in D6 parenthesis will turn to 1.  

 

4. Change to higher magnification. Once you get the TV value in low magnification field, 

change to high power to measure other parameters if necessary. To set the environment for 

higher magnification,   

If you use a stitched image, click Shrink/Expand Image 

button  in the Large Image Navigator window. The stitched 

image switches to full size and you can only see the upper-left 

part of it. Drag the small blue box in the Large Image Navigator 

window, which corresponds to the field shown in the Image 

Window, to the upper-left corner of previous defined tissue 

volume ROI. You need to click Redraw button or hit Ctrl+R, 

you will see the tissue volume ROI in a grey box. The full size 
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image will move accordingly. The size of the blue box is proportional to the field in the 

Image Window. It can be changed to facilitate the measurements if the features in the Image 

Window can be easily identified in lower magnification. Click  button, choose Pan Box Size 

among 1:1, 1:2, and 1:4 to zoom in/out. 

Click Move Clicked Point To Upper Left button  in the Large Image Navigator 

window, then cursor will appear in the Image Window as a blue arrow head with a red dot at 

the top. Align the red dot to the upper-left point of the grey ROI box, left click. Now, current 

field in the Image Window is aligned to the upper-left corner of the tissue volume ROI, as 

you can see in the Overview window. In ROI Tools window, choose Full Screen or an 

appropriate type to redefine the current ROI. Only the features in current ROI box (not the 

previous defined tissue volume ROI) will be measured. 

In the Overview window, you will see 2 boxes. The dotted-line box represents your 

current location of the field in the Imaging Window, and the solid-line box is the ROI defined 

for tissue volume. 

 

5. Measure bone volume (BV). Highlight D7 (bone 

volume) in the Select Arrays window. In the Threshold 

window, click    buttons to deselect them. If they 

turn grey, automatic thresholding will not get in the 

way.  

In Threshold Tools section in the Shelf window, click Draw Threshold icon 

 to draw the outline of trabecular bone. You can change the way of drawing 

by toggling Keyboard Termination, either hit Ctrl+K, click  in the Shelf 

window, or click Measure -> Keyboard Termination. Once you close the 

outline, click Fill Holes icon  and then click anywhere inside the outline to 

fill bone area. The outlined trabecular bone area will turn yellow. If you have 

multiple bone areas, outline and fill them individually; if you have a hole inside 

a bone, outline the hole as well, and it will be left blank when you fill the bone 

area. Click Dilate button  once in the Shelf window (you MUST click it if 

you want bone perimeter). You’ll benefit from it as it’ll make sure your BV 

touches the current ROI edge. Click Preview button in the Auto Measure 

window (make sure All is checked), then click bone area in the Image Window. 

When you see the outline turn blue, click Measure button. Bone volume values 

will show up in the List Current Arrays window. Now you can see the BV/TV 

value in the Calculations window.  

There are a couple of ways to define bone volume. For TRAP or H&E –

stained bone slices, manually drawing the outline would be a good way. Make 

sure your outlines touch the edge of current ROI, so that they will be ignored 

automatically from the bone surface calculation. Making changes to preview 

outlines by using Line Edit Tools is not recommended in this situation.  

 

6. Measure Ob.S/BS (osteoblast surface/bone surface) and Oc.S/BS (osteoclast 

surface/bone surface). Highlight L9 (Automatic Bone Perimeter) in the Select Arrays 

window. In the Auto Measure window, click Preview and click bone in the Image Window. 

Trabecular bone will be outlined in a different color. Now, make sure you check the 

Overview window. The bone outlines in pink should not appear on the edge of the white box, 

which means this part of the bone will be ignored in bone surface calculation. To define 
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OB/OC surface, click Segment Assign button in the Auto Measure window. When your 

cursor appears in the Image Window, move counterclockwise to click on both edges of an 

OB/OC. After you define both ends of an OB/OC, hit 1 for OB or 4 for OC. In both the 

Image Window and the Overview window, the defined line for OB/OC will be shown in a 

different color. 

If the bone outlines touching ROI show up in the Overview window, it may be because 

the bone outlines do not really touch ROI. Instead of re-outlining the bone, clicking Dilate 

button  in the Shelf window may be helpful. Maximizing the Overview window will make 

the lines easier to see, and click Resize To Fit button  to automatically fit the enlarged 

window. 

 

7. Measure N.Ob/BS (osteoblast number/bone surface) and N.Oc/BS (osteoclast 

number/bone surface). Highlight D9 (N.Ob, # Osteoblasts) or D10 (N.Oc, # Osteoclasts) 

in the Select Arrays window. BioQuant will calculate N.Ob/BS and N.Oc/BS by using 

previously defined bone surface. To obtain the best visual of the field, click Clear Overlay  

or Toggle Display Threshold  in the Shelf window if necessary. Choose manual measure 

mode by clicking Manual Measurement button  on main toolbar or clicking Measure -> 

Manual Measurement… from main menu. Click Measure button in the Manual window, and 

then click on each OB/OC in the Image Window. You will see symbol × is assigned to each 

OB/OC. Overview window will show them as well if you check Options -> Draw Point 

Mark. 

 

8. Once you finish all the measurements in the current field, move to next field. The way to 

move depends on the stitched image or manual move mode you are using (see page 10 for 

the details). Move several times to cover the whole tissue volume ROI and do measurements 

to every field. The measurements results will be updated automatically in the Calculations 

window. 

 

9. In a situation that one mouse has several slices which are stained differently, data from 

different slices can be stored into the same data set. For example, if you have a calcein 

double labeling slice in addition to a TRAP stained slice from the same mouse, you can add a 

new measurement to current data set by choosing Arrays -> Modify Data Set… from main 

menu. In Modify Data Set window, highlight Topo in Primary Arrays box, click Add Primary 

Array button ONCE. Now you will find an extra array in the Topo Array drop-down menu of 

Parameters window, which can be used to store the info of the new slice. If you have 2 more 

slices, click Add Primary Array button twice, so BioQuant will create two Topo arrays for 

you. Make sure you remember which Topo Array corresponds to which slice. 

 

10. To export the results into an Excel file, choose File -> Save Data, then File -> Data 

Manager. In the BIOQUANT Data Manager window, highlight BQDATA folder in the left 

box as shown below 
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Click Search for BIOQUANT Volumes button  on main toolbar, you will see all the data 

sets in the middle box. Icon  represents the data volume and icon  shows the data sets. 

Highlight them, and you’ll see the results 

appear in the right box. Click File -> 

Concatenate Data…, when you see the 

Concatenate Data window appears, highlight 

the data set you want to export in the middle 

box, click Add button in the Concatenate Data 

window. You’ll see your data set show up in 

the Data Sets to Concatenate box. Click To 

Excel button to export the data to excel 

spreadsheet file. If you do not want to see 

blank arrays, check Export Calculation Arrays 

Only box.  
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Moving to Next Field 
 

For stitched image mode 
 

1. In the Large Image Navigator window, click  button on the upper-left corner and choose 

Pan Box Step Size…, and make sure the value is 100. 100 means current field of view will 

move to next field in a 100% manner without any overlap. Move current field of view to next 

field by clicking Move Left  , Move Up  ,  Move Right  , Move Down  . Pay attention 

to the blue box in the Large Image Navigator window and the blue/white boxes in the 

Overview window when you’re moving the field, make sure they align well.  

 

2. When you move to a new field, change ROI as needed because only the features in current 

ROI box will be measured. When you click Redraw in the new field, if you see the blue box 

of tissue volume ROI inside the field, you have to draw a new ROI which is exactly the same 

as the blue box. To redefine a rectangle ROI, there is a better way other than typing in height 

and width values: choose Rectangle type, click Define ROI button, cursor switch to a dark 

blue box with a cross in the middle within the Image Window, hold down Shift key and move 

mouse to remove the box. Now use the cross to redraw a current ROI with left button, which 

should be within the tissue volume ROI.  

 

 

 

For Manual Move mode 
 

1. Highlight D17. Your current ROI will turn yellow. Select Full Screen type in ROI Tools 

window. Click Preview button in the Auto Measure window, then click in the Image 

Window. Right click. Click Measure button in the Auto Measure window, then click in the 

Image Window. You will see a red box that outlines the field. Right click. Click the camera 

icon  to get a live image. 

 

2. Use manual move  feature to move to new field of the blue ROI, using white box in the 

Overview window as guide. Use redraw to help match things up if you make a mistake with 

manual move (clicking twice ends the function, so if you double click before your move, you 

are unable to complete the manual move alignment). 

 

3. Once you are in the field you want to measure, click Redraw. You should see the boundary 

of what you have measured in Red and the boundary of your ROI in blue. To form the ROI 

for this field, select Irregular ROI from the ROI Tools window. Click Redraw. A teal box is 

now added in addition to the red and blue boxes. Click Keyboard Termination  in the Shelf 

window, and click Define ROI in the ROI Tools window. Use cursor and left clicks to draw 

the new ROI by following the boundaries of the screen and the red and blue ROIs. For the 

final segment, use spacebar to allow the program to close the ROI. If you make a mistake, hit 

Define ROI again and try again. 
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Calcein double labeling measurement 
 

 

1. MAR (Mineral Apposition Rate) and BFR (Bone Formation Rate) are the two major 

parameters to measure the bone formation activity. MAR measures the activity at the labeling 

area, whereas BFR calculates the activity from the overall bone surface. In order to monitor 

the overall bone formation rate, BFR divided by bone surface (BFR/BS) is better than BFR 

alone. The calculation of BFR involves single and double labeling, which means you have to 

outline both of them to get an accurate result. 

 

2. Define TV, BV and BS like we discussed above because you need comparable TVs and BS 

for calculation. Normally you can’t see nice parallel labels very much because of the 

curvature of trabecular bone. Only measure the parallel part for the double labeled surface 

and try your best to be consistent on how you choose that part. 

 

3. Define Labeling Period. Highlight D11 (Ir.L.t, Labeling Period) in the Selected box of 

Selected Arrays window. In List Current Array window, click Display List Menu button , 

and choose Edit Menu -> Append Data. Type in labeling period (days) in the Value To 

Append box. In Calculations window, find MAR and BFR/BS to see the results. MS/BS 

(mineralization surface / bone surface) is used for calculating BFR/BS from MAR. 

 

4. Measure Single Labeled Surface. Highlight L10 (sLS, 

Single Labeled Surface) in Selected Arrays window. 

Choose Manual Measurement and make sure Keyboard 

Termination is checked. Click Measure button, then click 

along the single labeled surface. Hit the space bar to 

terminate the measurement. 

 

5. Measure Double Labeled Surface. Highlight L11 (dLS, Double Labeled 

Surface) in Selected Arrays window. Choose Automatic Measurement, click 

dLS tab, and make sure Width is I2 and Surface is L11. Make sure Keyboard 

Termination in the Shelf window is checked. 

In dLS tab, click Draw Outer Label button, and cursor will appear in the 

Image Window as a red arrow head. Click to define the outer labels’ contour. 

Click Draw Inner Label button, define the inner labels’ contour. 

Once you right click to exit, you will see lines between the 

double labeling automatically drawn by the program. Click Save 

All Data button. Check Calculations window for results. Make 

sure your click on the same side of the double labeling. 

 

6. You can change the way program draws the double labeling lines by clicking  button in the 

dLS tab. In the most cases you don’t need to make any change to them, as the default setting 

works well. 

 

7. Move to next field as explained before and do the measurements. Keep doing this until you 

cover the whole tissue volume ROI. 
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Some useful features 
 

 

Save tracings on image 
      For some situations, it’s better to show bone slice picture along with its markings/tracings. For 

example, in a bone resorption experiment, as the staining backgrounds are usually very strong, they 

are much easier to see if the edges of pits are highlighted.  

      To do this, choose Option -> Save Tracings On Image from main menu before making any 

markings/tracings. Once you done with drawings, choose File -> Save Image(s) -> Save Single 

Image... 

 

 

Measure resorption/metastasis area 
      There are no pre-defined resorption or metastasis arrays in BioQuant, you can either manually 

define a pair of measurement array and calculation array, or simply consider BV (bone volume) as 

resorption/metastasis area.  

      To do this in a simple way, define a TV (tissue volume) first, and then draw 

resorption/metastasis areas as what you do for BV. For the BV/TV value, it can be seen as resorption 

area / total area in the case of a pit experiment, or as tumor volume / tissue volume in the case of a 

bone metastasis experiment. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


